Service Maintenance
Scheduled for Aug 3, 07:00 - 10:00 UTC
Update
To minimize any potential disruption that may occur during business hours globally, we have established a new planned date and timeframe for this maintenance switchover which will now take place August 3rd, Saturday, 7AM-10AM UTC.
Posted Jun 28, 2024 - 14:48 UTC
Update
Please be advised that the initial notification for this maintenance was incorrectly set for June 30th.

The correct date for this maintenance is July 30th and we have made the necessary update to reflect this.

We apologize for any concern or confusion caused by this error. Thank you.
Posted Jun 24, 2024 - 17:35 UTC
Scheduled
As part of our commitment to provide exceptional service and reliability to our customers, LastPass will be conducting service maintenance on the following date and time listed below. Our team will be taking all appropriate actions to minimize service interruptions during this event.

Date and Time: July 30, 2024, 06:00 AM UTC to 09:00 AM UTC

Maintenance objective: To switch operations to our Disaster Recovery region and conduct comprehensive testing to ensure our Disaster Recovery systems are fully operational and can support uninterrupted service in the event of a primary system failure.

Purpose: This maintenance is to ensure enhanced service reliability and continuity. In the unlikely event of a major disruption, our tested and validated Disaster Recovery systems will enable us to restore services quickly, minimizing downtime and maintaining the performance you rely on.

Duration: All maintenance will be planned to be performed within the 3-hours maintenance window.

What to expect: During this maintenance window, you may experience brief periods of reduced performance or intermittent connectivity issues. We anticipate these disruptions to be minimal, and our team will be closely monitoring the situation to ensure any issues are promptly addressed.
Posted Jun 24, 2024 - 13:45 UTC
This scheduled maintenance affects: LastPass - Australia, LastPass - United States, and LastPass - Europe.