Systems are operational and the incident is resolved
Posted Oct 30, 2025 - 00:04 UTC
Monitoring
Our third-party provider has applied fixes that are gradually resolving the issue. While many users are seeing improvements, some connectivity issues remain. We are actively monitoring the situation.
Posted Oct 29, 2025 - 21:34 UTC
Update
LastPass engineers continue to work with the cloud provider to resolve the issue.
Posted Oct 29, 2025 - 20:01 UTC
Identified
Our third party cloud provider has identified the issue and are now actively working towards a resolution. We will provide another update shortly.
Posted Oct 29, 2025 - 17:44 UTC
Investigating
We’re currently experiencing service degradation on LastPass's marketing site due to an issue with our external cloud provider. Our team is actively working to resolve the issue and minimize the impact.
Posted Oct 29, 2025 - 16:23 UTC
This incident affected: LastPass Marketing Website.