Access to the product was temporarily impacted for a limited subset of users, primarily those using certain web browsers. This was unintentionally triggered during the implementation of new security measures to protect our customers from emerging threats. The matter has been addressed, and we are not anticipating any further disruptions.
Date
Issue Start Time (ET): 11/21/2024 15:17
Issue End Time (ET): 11/21/2024 16:45
Products Impacted
LastPass
Root-Cause
Implementation of a bot mitigation measure that targeted to block a newly detected botnet.
Future Preventative Measures
Improve the assessment and validation of planned mitigation measures to reduce the potential impact to customers.
Posted Nov 25, 2024 - 16:42 UTC
Resolved
We have confirmed that the issue has been resolved. We will conduct an internal review of this issue to help prevent or minimize future recurrence and will publish our root cause analysis on this status page once this review has completed.
Thank you for your patience and understanding during this process. If you encounter any further issues, please don’t hesitate to contact our support team.
Posted Nov 21, 2024 - 04:27 UTC
Update
Earlier today we implemented security measures that caused login issues for some users.
We believe the issue has now been resolved, and we are actively monitoring our systems to ensure full operational stability. If you are still experiencing login issues we recommend temporarily switching to another browser. If the problem persists, please reach out to our Support team for further assistance.
Thank you for your patience and understanding. We will continue to keep you updated if necessary.
Posted Nov 21, 2024 - 01:52 UTC
Monitoring
Earlier today we implemented security measures that caused login issues for some users.
We believe the issue has now been resolved, and we are actively monitoring our systems to ensure full operational stability. If you are still experiencing login issues we recommend temporarily switching to another browser. If the problem persists, please reach out to our Support team for further assistance.
Thank you for your patience and understanding. We will continue to keep you updated if necessary.