LastPass - iOS Password Manager 6.10.0 experiencing slowdown in performance
Incident Report for LastPass
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted Jun 05, 2024 - 14:29 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

Our new iOS Password Manager 6.10.1 version has been released to all users. Please visit the App Store to update immediately.
Posted Jun 05, 2024 - 14:10 UTC
Identified
Our engineers believe they have identified the issue causing problems with version 6.10.0 of the LastPass Password Manager. Version 6.10.1 intends to fix the issue and will be available shortly in the App Store.
Posted Jun 05, 2024 - 12:55 UTC
Update
We have submitted a new iOS Password Manager 6.10.1 version which intends to fix the issue. This version is currently pending approval from Apple in App Store.
Posted Jun 05, 2024 - 11:42 UTC
Investigating
We are actively investigating reports that some LastPass customers may be experiencing a slowdown in performance with iOS Password Manager 6.10.0. Our engineers are working to identify the issue and will provide another update shortly.
Posted Jun 05, 2024 - 09:12 UTC
This incident affected: Mobile (iOS Password Manager).