Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 13, 2025 - 07:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 12, 2025 - 20:52 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 12, 2025 - 20:50 UTC
Scheduled
As part of our commitment to provide exceptional service and reliability to our customers, LastPass will be performing a scheduled update to prepare for the launch of our new Business offering (see below for the timeline). We are taking steps to minimize service interruptions and appreciate your understanding.
Maintenance Objective: LastPass will perform a series of upgrades to support the availability of our new LastPass Business SKU. Once complete, this upgrade will restore the ability to purchase LastPass Business as well as support our new LastPass Business offerings.
Time and Date: May 13, 2025 7:00 AM UTC to 1:00 PM UTC
What to Expect: During this maintenance window, purchasing our Business offering will be temporarily unavailable. All other offerings will remain accessible and fully functional.
Duration: All maintenance will be performed within the 5-hour maintenance window.
Posted May 12, 2025 - 20:45 UTC
This scheduled maintenance affected: Commerce System.