Issues with LastPass Login and Vault Access

Incident Report for LastPass

Resolved

We have confirmed that the issue has been resolved. We will conduct an internal review of this issue to help prevent or minimize future recurrence.
Posted Mar 24, 2026 - 13:19 UTC

Investigating

We are actively investigating reports that customers may be experiencing issues .

Our engineers are working to resolve the issue and will provide another update shortly.
Posted Mar 24, 2026 - 13:00 UTC
This incident affected: Login (MFA, EU, US, Other) and LastPass Support Site, Vault.