We have confirmed that the issue has been resolved completely, and all systems are 100% operational at this time. Our engineers identified an issue with the caching layer data base which was causing performance delays when attempting to load the download website, this has been corrected, and load times are now normal.
Posted Apr 01, 2025 - 14:05 UTC
Monitoring
Our engineers have identified an issue with the Redis caching layer which was causing performance delays when attempting to load the download website.
This issue has been resolved, and we are seeing page load times return to normal. We will continue to actively monitor the resolution and will provide another update shortly.
Posted Apr 01, 2025 - 13:22 UTC
Identified
Our engineers believe to have identified the issue and are now actively working towards a resolution.
We will provide another update shortly.
Posted Apr 01, 2025 - 13:04 UTC
Investigating
We are actively investigating reports that when attempting to download software (such as the LastPass extension) directly from the LastPass website, customers are experiencing performance delays which is causing the web page to load slowly.
All other services remain unaffected.
Posted Apr 01, 2025 - 11:32 UTC
This incident affected: LastPass - Australia, LastPass - United States, and LastPass - Europe.