LastPass - Unable to load web page intermittently
Incident Report for LastPass
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted Feb 26, 2020 - 09:52 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted Feb 26, 2020 - 09:44 UTC
Identified
Our engineers believe to have identified the issue and are now actively working towards a resolution.

We will provide another update shortly.
Posted Feb 26, 2020 - 09:40 UTC
Investigating
We are actively investigating reports that some LastPass customers may be experiencing issues intermittently when trying to access the web page https://lastpass.com. However, customers can access LastPass using the alternative link https://lastpass.com/?ac=1&lpnorefresh=1 to log into to their account as a workaround.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted Feb 26, 2020 - 09:30 UTC
This incident affected: LastPass - United States, LastPass - Europe, and LastPass - Australia.