Unable to download invoices

Incident Report for LastPass

Resolved

We have confirmed that the issue has been resolved. We will conduct an internal review of this issue to help prevent or minimize future recurrence.
Posted Oct 15, 2025 - 13:52 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 15, 2025 - 13:21 UTC

Identified

We are currently experiencing an issue that is preventing users from downloading invoices. Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.
Posted Oct 15, 2025 - 13:20 UTC
This incident affected: LastPass - Australia, LastPass - United States, and LastPass - Europe.