LastPass - Intermittent Issues Accessing Lastpass.com

Incident Report for LastPass

Postmortem

Summary

On February 25, 2025, an automated upgrade mechanism for our webservers was released and

encountered an issue which caused an error that impacted our customers’ ability to login.

Date

Issue Start Time (UTC): 25/02/2025 TIME 01:05 PM

Issue End Time (UTC): 25/02/2025 TIME 02:50 PM

Products Impacted

All LastPass Products.

Root-Cause

An automated upgrade of the Operating System layer triggered by our configuration

management tool encountered an error that unintentionally caused our web servers services to

fail and be unable to respond to any requests. That resulted in the LastPass website and service

being unavailable to customers for approximately 110 minutes.

Future Preventative Measures

We are continuously enhancing our monitoring process to promptly identify potential issues and

address them quickly if needed. Additionally, we are refining our automated procedures to

prevent upgrade tasks from causing unintentional unavailability of the platform during standard

work hours.

Related issues

N/A

Posted Mar 18, 2025 - 12:25 UTC

Resolved

We have confirmed that the issue has been resolved.

An automated process, which manages source-controlled configuration consistency of our infrastructure, incorrectly updated the configuration of front-facing servers. Engineers reverted the changes as part of mitigation.

A comprehensive root cause analysis (RCA) will be forthcoming with learnings and corrective actions to prevent its recurrence.
Posted Feb 25, 2025 - 15:11 UTC

Monitoring

Our engineers have corrected the issue and we have confirmed that all services are functional. If you are still experiencing issues, please clear your browser cache and try again. We will continue monitoring the situation and provide a final update shortly.
Posted Feb 25, 2025 - 14:02 UTC

Identified

Our engineers have identified the issue and are now actively working towards a resolution. Some users are still reporting intermittent issues. We will provide another update shortly.
Posted Feb 25, 2025 - 13:32 UTC

Monitoring

Our engineers have corrected the issue, and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted Feb 25, 2025 - 12:39 UTC

Investigating

We are actively investigating reports that the LastPass.com is currently inaccessible.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted Feb 25, 2025 - 12:17 UTC
This incident affected: LastPass - Australia, LastPass - United States, LastPass - Europe and Login (MFA, EU, US, Other).