LastPass - Intermittent Issues with Commerce Platform

Incident Report for LastPass

Resolved

We confirm that the issue is resolved and all systems are 100% operational. As always, we will conduct an internal review of this issue to help prevent / minimize future recurrence.
Posted Mar 24, 2025 - 15:10 UTC

Monitoring

We have detected an issue in our Commerce platform that prevented customers from saving new payment methods and making payments. Our engineers have corrected the issue and we are confirming that all services are functional. We will continue monitoring the situation and provide a final update shortly.
Posted Mar 24, 2025 - 14:11 UTC
This incident affected: LastPass - Australia, LastPass - United States, and LastPass - Europe.