We’re pleased to inform you that our scheduled maintenance and system testing have been completed earlier than anticipated. All systems are now fully operational.
Thank you for your patience and understanding during this time. If you encounter any issues or have any questions, please reach out to our support team.
Posted Aug 17, 2024 - 07:13 UTC
Update
We are still undergoing scheduled maintenance. We are on track, and no major issues have been found during the testing so far. We will provide updates as necessary.
Posted Aug 17, 2024 - 06:55 UTC
Update
We’re currently performing scheduled maintenance. We will provide updates as necessary.
Posted Aug 17, 2024 - 06:30 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 17, 2024 - 06:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 10, 2024 - 15:03 UTC
Scheduled
As part of our commitment to provide exceptional service and reliability to our customers, LastPass will be conducting service maintenance on the following date and time listed below. Our team will be taking all appropriate actions to minimize service interruptions during this event.
Date and Time: August 17, 2024, 06:00 AM UTC to 09:00 AM UTC
Maintenance objective: To ensure that LastPass remains compliant with the security requirements of our partners and vendors, we will need to update our database instances to renew our SSL/TLS certificates
Duration: All maintenance will be performed within the 3-hour maintenance window.
What to expect: - Purchase functionality will not be available - Invoice generation/download will not be available - Account information modification will not be available - Self-renewal functionalities will not work
This is a routine operation and we do not expect any other impact.
Posted Aug 09, 2024 - 14:03 UTC
This scheduled maintenance affected: LastPass - Australia, LastPass - United States, and LastPass - Europe.