LastPass Chrome Extension Issue
Incident Report for LastPass
Resolved
The LastPass Chrome extension has been restored. Our apologies for any inconveniences caused, and thank you for your understanding and patience.
Posted Jan 23, 2020 - 22:41 UTC
Update
We apologize for any frustration. The LastPass Chrome extension will be republished once it has finished being reviewed by Google.
Posted Jan 23, 2020 - 16:32 UTC
Identified
The LastPass extension in the Chrome Web Store was accidentally removed by us and we are working with the Google team to restore it ASAP. Thank you for your understanding and patience in the meantime.
Posted Jan 22, 2020 - 23:15 UTC
Update
We are actively investigating reports that LastPass customers are experiencing issues with downloading the Chrome Extension.

Our engineers are working with Google to resolve the issue and will provide another update shortly.

In the meantime: Please use our Web Vault, our Mobile App, or download the extension in another browser.
Posted Jan 22, 2020 - 19:16 UTC
Investigating
The Network Operations Center is investigating reports that Chrome users are experiencing 404 errors when downloading the LastPass Chrome Extension.

We have reached out to Google for assistance with this, and will provide another update shortly.
Posted Jan 22, 2020 - 18:01 UTC
This incident affected: LastPass - Australia, LastPass - United States, and LastPass - Europe.