Summary
On December 11, 2024, an infrastructure change caused an unexpected load in our core database impacting our customers' ability to login.
Date
Issue Start Time (UTC): 12/11/2024 4:46 PM (UTC)
Issue End Time (UTC): 12/11/2024 4:55 PM (UTC)
Products Impacted
All LastPass Products.
Root-Cause
Following a recent database upgrade, a snapshot caused an unanticipated increase in system load. The increased load resulted in a cascading impact on the database replication task, causing an interruption of service. As a result, the backend services were not able to respond to any request. This resulted in the system being unavailable for a period of 9 minutes.
Future Preventative Measures
We are committed to enhancing our monitoring process to promptly identify potential issues and address them quickly if needed. Additionally, we are refining our procedures to prevent maintenance tasks from causing unnecessary system load during standard work hours.
Related issues
N/A