LastPass - Account Provisioning Delays
Incident Report for LastPass
Resolved
We have confirmed that the issue has been resolved. To help prevent or minimize future occurrences, we will conduct an internal review. All customers who experienced issues with their purchases not being fully reflected should now see the problem resolved.
Posted Jan 16, 2025 - 18:13 UTC
Monitoring
Our engineers identified an issue causing delays in account provisioning after payment acceptance. A fix has been deployed to resolve the issue. We are actively monitoring and will provide another update once the resolution is complete.
Posted Jan 16, 2025 - 15:32 UTC
This incident affected: Commerce System.