LastPass Support - Third Party Phone System Outage
Incident Report for LastPass
Resolved
We have confirmed that the issue has been resolved.
Posted Nov 20, 2024 - 14:58 UTC
Monitoring
The provider has corrected the issue and they have confirmed that all services are functional. We will continue monitoring the situation and provide a final update shortly.
Posted Nov 20, 2024 - 14:25 UTC
Investigating
Our Support phone line is temporarily unavailable due to a service malfunction with our third-party provider. The provider is actively working to resolve the issue. In the meantime, if you need assistance, please log in to our Support Site and create a case. Our Support team is ready to address your requests immediately. Thank you for your patience and understanding.
Posted Nov 20, 2024 - 13:54 UTC
This incident affected: LastPass Support Site.