Lastpass - No outgoing emails.
Incident Report for LastPass
Resolved
The Network Operations Center has completed testing our Applications, all alerts have cleared, and this issue is closed. Please feel free to reach out to our Customer Care team by calling (866) 478-1805 should you have questions or comments.
Posted May 19, 2018 - 03:08 UTC
Investigating
The Network Operations Center is investigating an issue where customers may not receive emails from Lastpass.

We have engaged our on-call responders and we will provide another update as soon as able.
Posted May 19, 2018 - 02:55 UTC
This incident affected: LastPass - United States and LastPass - Europe.